Siebel 8.1 Web Client – User Id-Password is incorrect

I recently installed Siebel 8.1 on my system (in addition to Siebel 7.7 and Siebel 7.8). As I didn’t had my local extracted I copied my friends DBF file in Siebel\Tools\Local directory in order to explore the application.

I started Siebel Tools, put in local user id and password and logged in successfully (without any problems).  Then I opened dedicated client and entered same local username and password (the one I used for Siebel Tools) but I got and error saying

“User Id or Password entered is incorrect”

I checked the username and password but it was same that was used for Siebel Tools and had no problems. So, I stared looking at root cause of why this error is coming. Searching Web for this problem brought me suggestion like:

  • Copy “mwc_storage.xxx(actual name of the file is mwc_storage.cfg) from where I copied dbf to the client directory.  (This file is present in client directory but is of 0 bytes)
  • Delete *.SPF file from client directory.
  • Try replacing the SRF file

but nothing seemed to work. Then I saw somebody suggesting that go tinker with data sources.

When you install Siebel 8.1 (in fact any Siebel version) two data sources (System DSN) are created by default SEAW Local Db default instance (for Siebel Dedicated Client) and SSD Local Db default instance (For Siebel Tools)

SystemDSN

I went to Client Data Source (SEAW Local Db default instance ) and clicked on Test Connection button after enter my local username and password (in CAPS) as shown below

Test_Connection UserIdPwdPrompt

And received an error:

Selected database is already in use.

I went to database tab and deleted the information in present in Server Name and Start line field and reselected the DBF file using browse button and retested again and this time received message “Connection Successful”

DBFParameters

I tried opening the client after this and was able to open it successfully.

P.S: If it still doesn’t work for you try deleting same information from the tools data source also.

9 Responses to Siebel 8.1 Web Client – User Id-Password is incorrect

  1. hi,

    even without these settings, client can be opened if tools is kept open. same goes for dbisqlc too, but the database must be same for when the applications are opened.

  2. hi,

    even without these settings, client can be opened if tools is kept open. same goes for dbisqlc too, but the database must be same for when the applications are opened.

  3. and quite logical trying to open 2 times the same ODBC source whilst you want to go 2 different databases…no?

  4. The issue could also be because of the “.” present in 8.1 in Server name. If you replace “.” with “_” or remove “.” it will work.

  5. I checked the connection in odbcad32 and its showing connection successful for both local as well as server for client,but when i enter the same username and password while logging in the client it shows userid and password entered is incorrect.

  6. Issue is with diccache.dat.. copy the file from Root/siebsrvr/bin folder to your local client/bin

    Thanks & Regards
    Mohit Nawani

Leave a Reply

Contribute